Products | Versions |
---|---|
TIBCO Process Engine (Classic) | - |
Not Applicable | - |
Resolution:
Description:
============
There may be a requirement to update the license information for Process Engine, for example, to amend the number of allowable concurrent users. In order to generate a new license the current license key is required and this can be obtained by using the SWDIR/util/swconfig –v command, where SWDIR is the installation directory of the TIBCO Process Engine. If there is a problem with the license file the message 'Corrupt or Missing license file' may be displayed.
Environment:
==========
All supported versions of TIBCO Process Engine.
All supported operating systems and databases.
Symptoms:
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Running the command, SWDIR/util/swconfig –v, reports the message 'Corrupt or Missing license file' rather the license information.
Cause:
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The license file, SWDIR/staff.dat has become corrupt. The license file is an encrypted file so cannot viewed by a text editor to establish the corruption.
Resolution:
=========
If this problem occurs a new licence file must be created which can then be updated with a license key to provide the correct system configuration.
Perform the following steps to generate a new license.
1). Stop the TIBCO Process Engine (PE) and ensure no PE processes are running
2). Rename the SWDIR/staff.dat file to SWDIR/taff.dat.corrupt or something similar.
3). Run the following command to generate a new licence:
%SWDIR%\util\swconfig –n
4). Run the “swconfig –v” command to display the new demo license information.
5). Send new demo license information to the TIBCO Fulfillment team (fulfillment@tibco.com) who can provide the correct licence key to configure the system as require.
Note, in order for a new license key to affect the PE will have to be restarted.