The TIBCO iProcess Engine running on Windows sporadically stops responding to start or stop requests.

The TIBCO iProcess Engine running on Windows sporadically stops responding to start or stop requests.

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Article ID: KB0094469

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Updated On:

Products Versions
TIBCO iProcess Engine (Oracle) -
Not Applicable -

Description

Resolution:
Description:
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While running the TIBCO iProcess Engine (iPE) on Windows Server 2008, the processes sporadically stop responding to any user requests to stop or start the engine.

Environment:
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All supported versions of the TIBCO iProcess Engine on Windows
Windows Server 2008/ Windows Server 2008 R2 / Windows 7

Symptoms:
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The following symptoms have been observed for this issue -

1). The iPE engine will start up the initial processes (PROCMGR/BG/DLMGR/RPC_TCP_LI) but further processes will not be started.  After a few minutes the processes will begin crashing and the following entries are found in the Windows Event Viewer –
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The description for Event ID 0 from source TIBCO iProcess Engine cannot be found. Either the component that raises this event is not installed on your local computer or the installation is corrupted. You can install or repair the component on the local computer.
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If the event originated on another computer, the display information is saved with the event.

The following information was included with the event:

TIBCO iProcess Engine error : 0x80004005

StartSWEvent(): Failed to start Staffware Events COM+ Application
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2). While trying to access / shutdown the Staffware Events COM+ Application under Component Services, the following error is received.
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An error occurred while processing the last operation.  Error code 80004002 - No such interface supported.
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The event log may contain additional troubleshooting information.

3). The following steps can be taken which will allow iPE to start/stop again for a period of time
  
   a). Kill all dllhost.exe processes owned by the iPE background user.

   b). Kill all processes including the sentinels.

   c). Start iPE sentinels and processes.

Cause:
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The issue occurs due to the new User Profile Windows Service introduced in Windows Server 2008. This service is unloading the registry of the iPE background user while the COM+ service is still running as this same user causing the COM+ services to fail. Refer  to the Microsoft link provided under the References section for complete technical details.  

Resolution:
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A group policy change is required to counter the default behavior of the User Profile Windows service. The policy can be found in the group policy editor (gpedit.msc) Computer Configuration-&gtAdministrative Templates-&gtSystem-> UserProfiles

Do not forcefully unload the user registry at user logoff.

Change the setting from “Not Configured” to “Enabled”, which disables the new User Profile Service feature.

Note that this is a solution provided by Microsoft. In case of any concerns/queries, contact Microsoft Support.


References:
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http://blogs.msdn.com/b/distributedservices/archive/2009/11/06/a-com-server-application-may-stop-working-on-windows-server-2008.aspx

Issue/Introduction

The TIBCO iProcess Engine running on Windows sporadically stops responding to start or stop requests.