"DEPENDENCY CHECK FAILED" error when attempting to install BC Palette or EZComm Runtime 6.0.0 component.

"DEPENDENCY CHECK FAILED" error when attempting to install BC Palette or EZComm Runtime 6.0.0 component.

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Article ID: KB0088909

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Updated On:

Products Versions
TIBCO BusinessConnect -
Not Applicable -

Description

Resolution:
Description:
============
I want to install just the BusinessConnect Palette or EZComm Runtime 6.0.0 component on my private process side (BusinessWorks machine) without putting a full BC Server 6.0.0 installation on it. How can I achieve this?

Environment:
============
BusinessConnect 6.0.0 version


Symptoms:
=========
When attempting to install BC Palette 6.0.0, the following error is seen:
--------
>> DEPENDENCY CHECK FAILED:
>> The installation feature, BusinessConnect Palette, has failed an internal dependency check.
>> TIBCO BusinessConnect (6.0.0.0) or above is required and could not be located in the current  installation root directory.
>&gtPlease choose one of the following options.
--------

Cause:
======
The Installer is checking for the dependency and failing to install. This is a defect in BC Palette or EZComm Runtime 6.0.0. In general you should be able to install BC palette or EZComm Runtime component without BC server installation.

Resolution:
===========
Go to the BC Palette or EZComm Runtime 6.0.0 component installation directory and edit the "bcezcomm_FeatureConfig.xml" file and go to "BusinessConnect Palette" or "EZComm Runtime" section and comment the code like the following:

<!--&ltdependency description="TIBCO BusinessConnect" mustBeInstalled="true" parentID="bc" type="feature" uid="Interior Server_bc" version="6.0.0"/>-->

The installation can then be done.

Issue/Introduction

"DEPENDENCY CHECK FAILED" error when attempting to install BC Palette or EZComm Runtime 6.0.0 component.