The Adapter SDK properties are not visible for the ear in the TIBCO administrator GUI at service (.par) level.

The Adapter SDK properties are not visible for the ear in the TIBCO administrator GUI at service (.par) level.

book

Article ID: KB0088859

calendar_today

Updated On:

Products Versions
TIBCO Runtime Agent (TRA) -
Not Applicable -

Description

Resolution:
Description:
============
When uploading the ear file in the TIBCO Administrator GUI, the "Adapter SDK properties" are not visible under the service level (.par) under TIBCO administrator GUI -> Application Management->Application Name->Configuration.

Environment:
===========
All OS

Cause:
=====
The issue is because of the incorrect/corrupt bwengine.xml file under the TIBCO_HOME/bw/5.x/lib/com/tibco/deployment. when the ear is created with the incorrect bwengine.xml file in the TIBCO.xml under ear_file->Process Archive.par contains the wrong entries. The SDK properties are not visible in the administrator GUI. The cause of the incorrect bwengine.xml could be an incorrect installation or wrong manual update in the file.

Resolution:
==========
Workaround: Replace the bwengine.xml file from a correct installation of the same version. Restart TIBCO Designer and recreate the ear file. Another approach is to un-install and re-install the TIBCO ActiveMatrix BusinessWorks and recreate the ear file.

Issue/Introduction

The Adapter SDK properties are not visible for the ear in the TIBCO administrator GUI at service (.par) level.