The Adapter SDK properties are not visible for the ear file in the Administrator GUI at service (.par) level.

The Adapter SDK properties are not visible for the ear file in the Administrator GUI at service (.par) level.

book

Article ID: KB0088924

calendar_today

Updated On:

Products Versions
TIBCO Administrator -
Not Applicable -

Description

Resolution:
Description:
============
When we upload the ear file in the Administrator, the "Adapter SDK properties" are not visible under the service level (.par) under Admin GUI-> Application Management-&gtApplication Name-&gtConfiguration.

Environment:
===========
All OS

Cause:
=====
This is because of a incorrect/corrupt BWengine.xml file under the &ltTibco_Home>/bw/5.x/lib/com/tibco/deployment. When the ear file is created with the incorrect BWEngine.xml file the TIBCO.xml under ear_file-&gtProcess Archive.par contains the wrong entries, hence the SDK properties are not visible in the Administrator GUI.

The cause of the incorrect BWEngine.xml could be an incorrect installation or wrong manual update in the file.

Resolution:
==========
Replace the bwengine.xml file from a correct installation of the same version. Restart the Designer and recreate the ear file.

Another approach is to un-install and re-install BW and recreate the ear file.

Issue/Introduction

The Adapter SDK properties are not visible for the ear file in the Administrator GUI at service (.par) level.