Why is the Menu "RMS - Checkout" sometimes disabled after a successful login to the RulesManagement Server (RMS) ?

Why is the Menu "RMS - Checkout" sometimes disabled after a successful login to the RulesManagement Server (RMS) ?

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Article ID: KB0087973

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Updated On:

Products Versions
TIBCO BusinessEvents Enterprise Edition -
Not Applicable -

Description

Resolution:
Description:
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Why is the Menu "RMS -> Checkout" sometimes disabled after a successful login to the RulesManagement Server (RMS) ?

Environment:
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TIBCO BusinessEvents (BE) 5.0.1/4.0.2
All Operating Systems


Symptoms:
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Checkout option disabled.

Cause:
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The Checkout menu item will not be enabled if a local project is selected. The checkout operation results in project creation inside the workspace. If you have selected a project inside the workspace and perform a checkout it would mean the project would be nested under the selected project which it does not and hence would be misleading.

Resolution:
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Unselect the main folder in the Workspace by pressing Ctrl + click .

Issue/Introduction

Why is the Menu "RMS - Checkout" sometimes disabled after a successful login to the RulesManagement Server (RMS) ?