"NullPointerException at com.tibco.administrator.du.task.https.HttpsConfigureTask.setupInputParameters" in domainutility.log .

"NullPointerException at com.tibco.administrator.du.task.https.HttpsConfigureTask.setupInputParameters" in domainutility.log .

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Article ID: KB0074955

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Updated On:

Products Versions
TIBCO Runtime Agent (TRA) -
Not Applicable -

Description

Resolution:
Description:
============
While enabling the HTTPS transport for domain using the domainutilitycmd if the certificate type is SRVC (Install a server certificate),
the domainutilitycmd fails with the following error:
-------------
DU Error [DomainUtility] AESDKJ-0000 java.lang.NullPointerException at com.tibco.administrator.du.task.https.HttpsConfigureTask.setupInputParameters(HttpsConfigureTask.java:562)
-------------

Environment:
===========
All OS

Cause:
=====
CertificateDetails is missing in domainutilitycmd task file "EnableHttpsConf.xml".
 

Issue/Introduction

"NullPointerException at com.tibco.administrator.du.task.https.HttpsConfigureTask.setupInputParameters" in domainutility.log .

Resolution

Please check "EnableHttpsConf.xml" your domainutiltiycmd task file. They should match with the ones when you create the Certificate Sign Request (CSR).
A good option is to modify the "EnableHttpsConf.xml" file you used to create the CSR by changing <CertificateType> to SRVC, then provide ServerCertificate and CAChainCertificate information. Missing the CertificateDetails information could cause such NullPointerException.

        <CertificateDetails>
            <Email>email@mycompany.com</Email>
            <CN>my.mydomain.com</CN>
            <OU>my organization unit</OU>
            <O>my organization</O>
            <City>my city</City>
            <State>my state</State>
            <CountryCode>US</CountryCode>
            <Validity>730</Validity>
        </CertificateDetails>


Please contact TIBCO support if further help is needed.