In BusinessEvents 4.0.1, Inference Agent(IA) hangs with driver.jms errors.

In BusinessEvents 4.0.1, Inference Agent(IA) hangs with driver.jms errors.

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Article ID: KB0087977

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Updated On:

Products Versions
TIBCO BusinessEvents Enterprise Edition -
Not Applicable -

Description

Resolution:
Description:
=========
In BusinessEvents 4.0.1, Inference Agent(IA) hangs with driver.jms errors.

Environment:
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TIBCO BusinessEvents
WebSphere MQ



Symptoms:
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Inference Agent throws the following errors and then hangs:

2012 May 12 22:03:57:478 GMT -4 QP_BE_APV_IE-QP_BE_APV_IE-2 Error [pool-41-thread-1] - [driver.jms] inference-class
2012 May 12 22:03:58:756 GMT -4 QP_BE_APV_IE-QP_BE_APV_IE-2 Error [pool-42-thread-1] - [driver.jms] inference-class
2012 May 12 22:03:59:228 GMT -4 QP_BE_APV_IE-QP_BE_APV_IE-2 Error [pool-39-thread-1] - [driver.jms] inference-class
2012 May 12 22:04:00:119 GMT -4 QP_BE_APV_IE-QP_BE_APV_IE-2 Error [pool-40-thread-1] - [driver.jms] inference-class


Cause:
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The error was seen in the logs because WebSphere® MQ fails to format a new log because of lack of disk space.


Resolution:
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Increase the log size value as per project requirements and make sure that MQ server has enough space to write to the log to perform its operations.


References:
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http://publib.boulder.ibm.com/infocenter/wmqv6/v6r0/index.jsp?topic=%2Fcom.ibm.mq.amqzag.doc%2Ffa14600_.htm

Issue/Introduction

In BusinessEvents 4.0.1, Inference Agent(IA) hangs with driver.jms errors.