TIBCO BusinessEvents Log file isn't created in specified folder when deployed in TIBCO Administrator.

TIBCO BusinessEvents Log file isn't created in specified folder when deployed in TIBCO Administrator.

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Article ID: KB0091150

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Updated On:

Products Versions
TIBCO BusinessEvents Enterprise Edition -
Not Applicable -

Description

Resolution:
Description:
===========
Configuring the location of BusinessEvents logfile on deployment using TIBCO Administrator.

Environment:
===========
All Versions
All Operating Systems


Symptoms:
=========
On deployment of BusinessEvents Application using TIBCO Administrator the logfile will be created in TRA_HOME/domain/MY_DOMAIN/application/logs. The logfile folder settings in Cluster Deployment Descriptor (CDD) file will be ignored.

Cause:
======
This is the expected behaviour for applications deployed with TIBCO Administrator to allow to visit the logfile in Administrator (Browser).

Resolution:
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Create a link to the TRA_HOME/domain/MY_DOMAIN/application/logs.

Note:
------
The TRA property of the deployed application "Engine.Log.Dir" defines the log directory. If you comment out that property the log directory of CDD is used (not recommended).

Issue/Introduction

TIBCO BusinessEvents Log file isn't created in specified folder when deployed in TIBCO Administrator.