How to troubleshoot TIBCO ActiveMatrix BusinessWorks Fault Tolerance issues.

How to troubleshoot TIBCO ActiveMatrix BusinessWorks Fault Tolerance issues.

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Article ID: KB0090625

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Updated On:

Products Versions
TIBCO ActiveMatrix BusinessWorks -
Not Applicable -

Description

Description:
This articles discusses troubleshooting TIBCO ActiveMatrix BusinessWorks Fault Tolerance (FT) issues.
Symptoms:
You can see both BW FT instances are in a running state.
Cause:
This can be caused by any of the following:

1). Incorrect RVFT transport parameter configuration.
2). RVRD configuration.
3). Network problem preventing the exchange of heartbeat messages.

Issue/Introduction

How to troubleshoot TIBCO ActiveMatrix BusinessWorks Fault Tolerance issues.

Resolution

TIBCO ActiveMatrix BusinessWorks uses RVFT for implementing fault tolerance. If there is an issue with the status of BW FT applications, then check the following:

1). BW fault tolerance engines are running in the same subnet or a different subnet. If they are running in a different subnet, then the RVRD needs to be configured so that two engine instances can exchange RVFT heartbeat messages, which are required for FT operation.

2). Check if heartbeat messages are being received on the machine running the BW instances. This can be done by :

    tibrvlisten "_RVFT.ACTIVE_HB.<FT subject name>"

    The <FT subject name> is specified in deployed application .tra file: Engine.FT.Subject=<subject>

    If there is no heartbeat messages, it indicates a network or RVFT configuration problem.