SYS_ERROR (space_def_mismatch) AS (Active Spaces) Exception on TIBCO BusinessEvents Cache Agent startup.

SYS_ERROR (space_def_mismatch) AS (Active Spaces) Exception on TIBCO BusinessEvents Cache Agent startup.

book

Article ID: KB0090588

calendar_today

Updated On:

Products Versions
TIBCO BusinessEvents Enterprise Edition -
Not Applicable -

Description

Resolution:
Description:
===========
The following project architecture resulted in “Space_Def_Mismatch” error:

Machine 1: One Cache Server and One Inference Agent
                
Machine 2: One Cache Server and One Inference Agent (same project as Machine 1), in this machine use the Discover URL as “tcp://machine1:&ltport>” as we are starting the Cache and Inference on Machine 1 before-hand.

The cluster on one machine starts up fine. But, when Cache server running on second machine starts up it joins the cluster successfully but it throws a “Space_Def_mismatch” error.

Environment:
============
TIBCO Business Events 5.x, Datagrid as Cache provider

Symptoms:
==========
Cache Server throws “Space_Def_mismatch” error and fails to startup.

Cause:
======
When space is being defined on cache agent startup it checks to see if there is existing spacedef for the given space name. If so it compares to see if space definition is same. If there is a mismatch in any spacedef attribute/field definition/index definitions the cache agent throws the space_def_mismatch exception.

In the scenario highlighted under “Description” the cache server on Machine 1 had different space settings and Cache Server on machine 2 had different space settings due to different values used for “entity-cache-size” and object table --> “max-size” property in CDD file.  This resulted in space_def_mismatch error.

Resolution:
===========
Make sure space settings are same between projects running on different machines where agents are trying to join the same cluster.

Issue/Introduction

SYS_ERROR (space_def_mismatch) AS (Active Spaces) Exception on TIBCO BusinessEvents Cache Agent startup.