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Article ID: KB0090392
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Description
Description:
Description:
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Under some circumstances Process Manager does not continue a process which was waiting for an external event (such as a user task, signal, or timer).
Environment:
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TIBCO ActiveMatrix BPM versions 1.3.1.0 to 1.3.1.5 on any supported platform.
Symptoms:
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Sometimes, when a process is waiting for an external event (such as for a user task to complete, for a subprocess to complete, for a timer, for an incoming signal), it does not continue when the event is received. No error message is displayed, and no information associated with this failure is posted to the audit trail.
You can detect such stalled processes by running an SQL query similar to the following:
select wi.QUEUE_ID from PVM_WORK_ITEM wi where wi.IS_DONE = 0
and wi.QUEUE_ID not in (select DATUM from PVM_REQUEST_QUEUE
where STATUS = 0) and wi.QUEUE_ID in (select pt.PROCESS_ID from
PVM_PROCESS_TRACKER pt where wi.QUEUE_ID = pt.PROCESS_ID
and pt.ENGINE_ID = -1)
This SQL query can show false positives in some cases. This query will return suspended processes that have pending events. If these processes were intentionally suspended, they should be ignored.
You can also check the audit trail to find the process instances returned by the SQL query. Compare the status of these instances with the expected tasks and sequence flow. If this does not match the expected pattern of failing to progress after an external event, contact TIBCO Support.
Cause:
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This is caused by a timing issue in the process engine.
Resolution:
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As a workaround, suspending and resuming the process may progress the task.
This problem was fixed in TIBCO ActiveMatrix BPM 1.3.1-HF006, and also in TIBCO ActiveMatrix BPM 2.0. Customers are therefore recommended to upgrade their installation:
• Preferably to the latest version, TIBCO ActiveMatrix BPM 2.1,
• Or else to TIBCO ActiveMatrix BPM 1.3.1-HF008.
Although this problem was fixed in HF006, TIBCO recommends upgrading to the latest 1.3.1 hotfix (HF008) instead, to include other important fixes.
If the upgrade and/or the workaround mentioned above do not progress all stalled processes, the symptoms may result from a different cause. Contact TIBCO Support for further assistance.
Symptoms:
Cause:
Issue/Introduction
This advises users to upgrade TIBCO ActiveMatrix BPM to avoid processes stalling when waiting for an external event.