BW application log file is not rotating.

BW application log file is not rotating.

book

Article ID: KB0090352

calendar_today

Updated On:

Products Versions
TIBCO ActiveMatrix BusinessWorks -
Not Applicable -

Description

Resolution:
Description:
============
BW application log file is not rotating.


Environment:
===========
BW: ALL

Symptoms:
========
BW log file is not rolling over properly after reaching to the maximum size. The BWEngine continues to write to the same log file. The chosen log file is random.

Cause:
=====
This is caused by file locking. If any other programs (such as write to file or Hawk monitoring) is running on the log file, could create such issues. It happens more frequently when log roll over happens within a short span of time. It could also can happen due to duplicate monitoring rules.

Resolution:
==========
Increase the log file size and remove duplicate (redundant monitoring rules).

Issue/Introduction

BW application log file is not rotating.