RosettaNet PIPs terminate unexpectedly after upgrading to BusinessConnect 6.X.

RosettaNet PIPs terminate unexpectedly after upgrading to BusinessConnect 6.X.

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Article ID: KB0090348

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Updated On:

Products Versions
TIBCO BusinessConnect RosettaNet Protocol -
Not Applicable -

Description

Resolution:
Description
==========
With BC 5.X and BCRN 5.2 we were able to exchange RosettaNet transactions with our trading partner's test server with no problems. After upgrading to BC 6.X, the following error is returned from the trading partner:

PIP terminated - error sending HTTP/S message to https://&lttp URL>  received HTTP response "699". Header processing error: HTTP/1.1 400 Bad Request [Content-Type: text/html, Date: Wed, 13 Jun 2012 14:07:58 GMT, Connection: close, Content-Length: 42]: Bad Request

Environment
===========
TIBCO BusinessConnect 6.X.X
TIBCO BusinessConnect RosettaNet Protocol 5.2.0

Cause
===========
Additional header information in the HTTP header that BusinessConnect sends to the trading partner is causing the PIP to fail.

Resolution
==========
This is a known issue.  The issue can be resolved  by adding the following property to the BC settings as follows:

1).  Go to Administrator&gtBusinessConnect&gtSystem Settings&gtInstalled Protocol&gtBC Server. A list of properties appear.

2).  Add the following Boolean property:

bc.http.request.useDateHeader

and leave it unchecked (default).

3).  Save the settings.

4).  Restart all BC engines.

Issue/Introduction

RosettaNet PIPs terminate unexpectedly after upgrading to BusinessConnect 6.X.