TIBCO BusinessEvents 5.1.1 version is not displayed/listed in the Installed Software section of TIBCO Administrator.

TIBCO BusinessEvents 5.1.1 version is not displayed/listed in the Installed Software section of TIBCO Administrator.

book

Article ID: KB0090332

calendar_today

Updated On:

Products Versions
TIBCO BusinessEvents Enterprise Edition -
Not Applicable -

Description

Resolution:
Abstract
========
TIBCO BusinessEvents 5.1.1 version is not displayed/listed in the Installed Software section of TIBCO Administrator.

Description:
===========
According to our product readme file, TIBCO Business Events 5.1.1 requires that the  following TIBCO products are already installed if you want to deploy Business Events 5.1.1 applications in TIBCO Administrator:

TIBCO Administrator-Enterprise Edition 5.7.1 --- 5.8.0
TIBCO Runtime Agent 5.7.4 --- 5.8.0 (required if deploying TIBCO required if deploying TIBCO BusinessEvents applications via TIBCO Administrator-Enterprise Edition)

When running TIBCO Runtime Agent version lower than 5.7.4 you might run into issues where TIBCO BusinessEvents 5.1.1 is not listed in the installed software section of TIBCO Administrator or sometimes there will be issues deploying the 5.1.1 Enterprise Archive (EAR) with errors such as container missing, etc.

Environment:
==========
TIBCO Business Events 5.1.1 standard and add-on products, Linux operating System

Symptoms:
=========
TIBCO Business Events 5.1.1 is not listed in the Installed Software section of TIBCO Administrator. In some cases even if it is visible you will run into issues deploying 5.1.1 EAR (Enterprise Archive) file. The most common is a missing container.

Cause:
========
On LINUX, when using TIBCO Runtime Agent version less than 5.7.4 there is an issue where the build version for BusinessEvents 5.1.1 was taken as 35.1 and we saw number format exception in TSM.log file. To confirm this can you verify following:

- Take a backup and remove all the TSM logs from &ltDOMAIN_HOME>/logs.

- Open hawkagent.cfg file and set the -tsm_traceLevel to -1 and restart your hawk agent.

- Now open the TSM log file and check if there is a Number Format Exception when loading version 5.1.1 of TIBCO Business Events.

- If there is a Number Format Exception then follow steps listed in RESOLUTION to get around the issue.

On Windows the build version 35.1 is stripped off the decimal digits and the upgrade version is taken as 35 but on Linux the build version is taken as it is resulting in Number Format Exception in TSM.log.

Resolution:
=========

- Uninstall BusinessEvents 5.1.1 from your machine using the "Universal installer" under &ltTIBCO_HOME>/tools/universal_installer. Validate if 5.1.1 is uninstalled successfully, you can do this by checking if _InstallInfo folder doesn't contain 5.1.1 related XMLs.

- STOP all TIBCO Processes running on the box like Hawk Agents, Domain Admin process and any other TIBCO processes.

- As a workaround make a backup of original files and edit the "product_businessevents-standard_5.1.1_FeatureConfig.xml" file which comes with installer for standard as well as any XMLs related to add-ons to change Buildversion 35.1 to 35 and reinstall BusinessEvents 5.1.1.

- This time when you restart the Hawk Agent the BE version 5.1.1 should show up under "Installed Software" in Admin GUI and your deployment of 5.1.1 EAR (enterprise archive) should go through.

Issue/Introduction

TIBCO BusinessEvents 5.1.1 version is not displayed/listed in the Installed Software section of TIBCO Administrator.