CustomerValidation errors during the generation of a HIPAA 999 or TA1 acknowledgement.

CustomerValidation errors during the generation of a HIPAA 999 or TA1 acknowledgement.

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Article ID: KB0090833

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Updated On:

Products Versions
TIBCO BusinessConnect EDI Protocol HIPAA Edition Powered by Instream -
Not Applicable -

Description

Resolution:
Description
==========
A validation error occurs when generating an acknowledgement when processing an inbound HIPAA transactions such as an 834.  

Environment
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Applies to all operating systems , EDI 6.X, HIPAA 6.X

Symptoms:
=========
Processing of the HIPAA  transaction fails with validation error and in the logs ("Resgen exception"):  "The EDI document was processed successfully but encountered transactions with conversion errors. Instream validation error. Return Code : 186; Message : Resgen failed error : 110."

Cause
===========
This issue is caused because of the use of a "normal" 834 guideline (unencrypted) to generate HIPAA ack (999, 824, 277) rather than the encrypted guidelines. Any guideline that starts with PDSA OR PDSX is an encrypted guideline(eg PDSA5010834.std).

Resolution
==========
To process HIPAA transactions such as 834 with HIPAA acks to be generated, use encrypted guidelines that starts with either PDSA (1-7 SNIP level ) or PDSX (1-2 SNIP level) shipped with EDI HIPAA installation in the folder  EDI_HOME/instream/Database/ . These guidelines consist of  special records that are essential to Instream creating any type of response. If you want to set any SNIP levels, you need to develop a custom apf file based on "apf" doc that comes with the Foresight installation. You cannot modify encrypted guidelines but if you do have to modify these guidelines, contact Foresight to get the unencrypted versions of these guidelines.

Issue/Introduction

CustomerValidation errors during the generation of a HIPAA 999 or TA1 acknowledgement.