Error: "Current user does not have 'view' permission to Application com.tibco.amx.bwse.application."

Error: "Current user does not have 'view' permission to Application com.tibco.amx.bwse.application."

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Article ID: KB0090388

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Updated On:

Products Versions
TIBCO ActiveMatrix Service Grid -
Not Applicable -

Description

Description:
User with view permission on an application failed to access that application due to the error, "Current user does not have 'view' permission to Application com.tibco.amx.bwse.application"
Symptoms:
Error: "Current user does not have 'view' permission to Application com.tibco.amx.bwse.application" will pop up though the user trying to view a specific application has the required permission on that application.
Cause:
The error happens when the application has a dependency on the System application 'com.tibco.amx.bwse.application'. Since the user does not have view permission on the system application 'com.tibco.amx.bwse.application',  this error will be displayed when trying to view details of the application.

Issue/Introduction

Error: "Current user does not have 'view' permission to Application com.tibco.amx.bwse.application."

Resolution

Login with SuperUser credentials. Go to Applications and select the environment for the application. Expand the System folder .Select 'com.tibco.amx.bwse.application' and set the permission for the user. After this the user should be able to view the specific application .