Resolution: Description:
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For some deployed applications, the Tracing tab in the Admin GUI shows duplicate entries. The application log file shows them only once.
Environment:
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TIBCO Administrator 5.x.x
TIBCO Runtime Agent 5.x.x
OS : All
Symptoms:
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Below is an example where application log shows below line only once whereas Tracing tab in Admin GUI shows the same line four times.
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27-Apr-11 16:42:54 EDT Canada/Eastern User - Job-60943 [ReceiveMessageFromComponents.process/Log-1]: Received message from component. Message ID: 160 details
27-Apr-11 16:42:54 EDT Canada/Eastern User - Job-60943 [ReceiveMessageFromComponents.process/Log-1]: Received message from component. Message ID: 160 details
27-Apr-11 16:42:54 EDT Canada/Eastern User - Job-60943 [ReceiveMessageFromComponents.process/Log-1]: Received message from component. Message ID: 160 details
27-Apr-11 16:42:54 EDT Canada/Eastern User - Job-60943 [ReceiveMessageFromComponents.process/Log-1]: Received message from component. Message ID: 160 details
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Cause:
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The data displayed in the Tracing tab in the Admin GUI is displayed after parsing the application log file. Sometimes the data from the application log is not parsed correctly causing this issue to occur.
Resolution:
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This issue is resolved after undeploying, deleting and redeploying the affected application(s).
If this does not resolve the issue, issue the following:
1). Stop the affected application.
2). Go to <TIBCO home>/tra/domain/<domain name>/application/logs dir .
3). Locate the log file for the affected application and delete it.
4). Restart the application.
If the above steps do not help, start the application from the command line instead of the Admin GUI. Capture the messages from the command window in a file and send the file to TIBCO Support for review.