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Article ID: KB0086567
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Updated On:
Description
Resolution:
Description:
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After the installation of TIBCO BusinessEvents(BE) 5 hotfix engineering build, it was showing BE software as UnInstalled and disabled. Once we rollback the BE5 hotfix, it's showing all the previous existing software's stack.
Environment:
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TIBCO BusinessEvents 5.1.1
TIBCO BusinessEvents 5.1.1 hotfix engineering build
TIBCO Administrator
TIBCO Hawk
TIBCO UniversalInstaller 3.2.0 V2 and above
Cause:
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Check the buildNumber from "_FeatureConfig.xml" under the unzipped engineering build installation file, or from "_prodInfo.xml" file under <BE_HOME>/_installInfo folder and see if the buildNumber is in TimeStamp format, e.g. "2013-08-09-15-13-52".
There was an issue with TIBCO Administrator/Hawk regarding the build number in this format. The Hawk agent will not pick up BE and will throw a lot of errors, hence as a result you will see software as uninstalled in TIBCO Administrator.
Resolution:
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Use the one of following method to work around this issue:
1). Before installing the engineering build, modify all the "**_FeatureConfig.xml" files. Change the buildNumber to format "V+Number", e.g. V90 instead of the timestamp format value and save the file. Then install the build.
2). If you already have the engineering build installed, modify all "_prodInfo.xml" files under _installInfo folder which contains buildNumber in timestamp format.
For example, modify every instance of buildNumber=" 2013-08-09-15-13-52" to buildNumber="V90" under TIBCO_HOME/_installInfo/*.xml
Now start the Hawk agnet.
Issue/Introduction
TIBCO BusinessEvents shown asuninstalled in TIBCO Administrator after installing hotfix engineering build for 5.1.1