Products | Versions |
---|---|
TIBCO BusinessConnect | - |
Not Applicable | - |
Resolution:
Description
==========
On UNIX systems with the umask value of 022, BC processes the file but does not set the permission to 644. What needs to be done to get the correct permissions of 644?
Environment
===========
TIBCO BusinessConnect 5.X.X and 6.X.X
Cause
===========
The user permission and umask setting are governed by the hawkagent that starts BC when started from the Administrator.
Resolution
==========
Check what user starts the Hawk agent in your environment and make sure that the umask setting is correct for that user. Alternately, add the umask setting into the .sh file that starts BC to accomplish the same thing.