When importing an existing trading partner or operation into BusinessConnect, the previous setting for the trading partner remain in force, and the new settings are not imported.

When importing an existing trading partner or operation into BusinessConnect, the previous setting for the trading partner remain in force, and the new settings are not imported.

book

Article ID: KB0085990

calendar_today

Updated On:

Products Versions
TIBCO BusinessConnect -
Not Applicable -

Description

Resolution:
Description
==========
When importing an existing trading partner or operation into BusinessConnect, the previous setting for the trading partner remain in force, and the new settings are not imported.

Environment
==========
BusinessConnect 5.X and 6.X

Cause
===========
The import function will try to "merge" the settings from the import with the existing setting for the trading partner or operation.  If the property is already set in the trading partner or operation, the import function will not overwrite these settings. The import function is mainly to allow customers to move settings from an existing installation to a new one, and will prevent an overwrite of existing information. This is done mainly to protect production environments from accidental changes.

Resolution
==========
If updating trading partner or operation setting via an import, delete the previous trading partner or operation from BusinessConnect prior to the import. If you would like to modify the settings dynamically, consider using the BusinessConnect ConfigStore Management Protocol plugin which allows for trading partner or operation modification via BusinessWorks.

Issue/Introduction

When importing an existing trading partner or operation into BusinessConnect, the previous setting for the trading partner remain in force, and the new settings are not imported.