The TIBCO BusinessEvents (BE) views of data is not getting rolled over.

The TIBCO BusinessEvents (BE) views of data is not getting rolled over.

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Article ID: KB0087600

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Updated On:

Products Versions
TIBCO BusinessEvents Enterprise Edition -
Not Applicable -

Description

Resolution:
Description:
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The data displayed from the chart always shows all of the data and never changes even though the logs may indicate that a roll over has happened.

Environment:
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BE 4.0.x and 5.x

Cause:
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For roll over to happen the chart must be date aware and CDD file must have the proper settings. See page 48 table 10 of "TIBCO BusinessEvents Views Developer’s Guide" for BE 4.0.2 for the correct settings.

Resolution:
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Once the settings are in place in the CDD file confirm that the chart is date aware. To make a chart day aware look at debit and fraud traffic in the FraudDetection dashboard example. Basically your metric needs to have datetime group by field. Your data source should use that datetime field with bindings and your chart should set the binding variables to #STARTOFDAY, #ENDODDAY, #TODAY etc.

Issue/Introduction

The TIBCO BusinessEvents (BE) views of data is not getting rolled over.