Custom logging using log4j does not work after upgrading BW from 5.8 to 5.9/5.10/5.11

Custom logging using log4j does not work after upgrading BW from 5.8 to 5.9/5.10/5.11

book

Article ID: KB0089418

calendar_today

Updated On:

Products Versions
TIBCO ActiveMatrix BusinessWorks -
Not Applicable -

Description

Resolution:

Description:
============

Custom logging using log4j does not work after upgrading BW from 5.8 to 5.9/5.10/5.11 .

Environment:
===========

TIBCO BusinessWorks 5.9.x, 5.10, 5.11


Symptoms:
========

Custom logging does not work and log files are not created as per the configuration in log4j.properties.

Cause:
=====

TIBCO BusinessWorks 5.8 loads the properties from log4j.properties by default, but starting from BW 5.9, the log4j properties are being loaded from log4j.xml by default. All BW 5.9+ versions will load the log4j configuration from log4j.properties file only if the log4j.xml is absent.

Resolution:
==========

1). Add the following property to the deployed application .tra file or designer.tra if running in Designer:

   java.property.log4j.configuration=file:///C:/tibco/bw/<version>/lib/log4j.properties
  
This property will force BW to pick the log4j configuration from log4j.properties instead of log4j.xml .
  
2). Configure the external logging in log4j.xml instead of log4j.properties.

Issue/Introduction

Custom logging using log4j does not work after upgrading BW from 5.8 to 5.9/5.10/5.11