Pending Orders in Execution Status with no obvious error.

Pending Orders in Execution Status with no obvious error.

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Article ID: KB0089360

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Updated On:

Products Versions
TIBCO Fulfillment Order Management -
Not Applicable -

Description

Description:
Under stress circumstances, a few orders remain blocked in execution status without any apparent reason.
Symptoms:
Logs do not show any errors or exceptions that could explain this behavior. Similar orders are completed successfully.

Cause:
Due to stress conditions, an internal event that notifies the orchestrator to start the execution of the corresponding plan item has been lost.
It will not be executed and the related order will never complete.This is actually a defect in BE 5.1.1 HF5.  A Jira ticket has been opened to track it (BE-20102).        

Issue/Introduction

Pending Orders in Execution Status with no obvious error.

Resolution

Unfortunatety, there is no way to resume the execution of the pending orders but there is a workaround to avoid this situation. It consists of disabling the BE L1 cache (deactivation of cache). To do this, edit the orchestrator cdd file and:  

1). Add the property "be.om.localCache.className" in the agent class level for the Inference Agent as follows:
===============
<inference-agent-class>
......

    <property-group>
          <property name="be.om.localCache.className" value="com.tibco.cep.runtime.service.om.impl.invm.NoOpLocalCache"/>
    </property-group>
</inference-agent-class>
=================

2). Set the local cache size to 0 in " agent-classes-> inference-agent-class -> local-cache"(default is 1024).
=========
<local-cache>
    <eviction>
        <max-size>0</max-size>
        <max-time>900</max-time>
    </eviction>
</local-cache>
========