Service Agent in BW fails with "Activation Error".

Service Agent in BW fails with "Activation Error".

book

Article ID: KB0089068

calendar_today

Updated On:

Products Versions
TIBCO ActiveMatrix BusinessWorks -
Not Applicable -

Description

Description:
Unable to start the engine. It throws the following exception. The stack trace is printed in the log file.

caused by: An IOException occurred while initializing the service
caused by: com.tibco.plugin.share.jms.impl.ActivityExceptionWrapper

Symptoms:
Activation error with plugin agent [BusinessProcesses/Voucher Management Interface/StarterProcesses/VoucherManagement-Service-v1.1.0.serviceagent]
caused by: An IOException occurred while initializing the service
caused by: com.tibco.plugin.share.jms.impl.ActivityExceptionWrapper
Cause:
This error indicates that there is a problem with the JMS transport., caused by losing permission in the topic.

Issue/Introduction

Service Agent in BW fails with "Activation Error".

Resolution

Fix the issue on the JMS server side by providing permission to the topic.