All participants are not getting imported into a BusinessConnect installation.

All participants are not getting imported into a BusinessConnect installation.

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Article ID: KB0088916

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Updated On:

Products Versions
TIBCO BusinessConnect -
Not Applicable -

Description

Description:
When you import a .csx file which was exported out from BC 6.0.1, 6.0.2  with an HF1 environment into another BC 6.1.0 or 6.0.2 environments, we observe that not all the participants are getting imported.

Symptoms:
When logging into the Administrator after importing a .csx that was previously exported out from bc 6.0.1 or bc 6.0.2 (including HF1), all participants are not imported. No exceptions are found in the log files.

Cause:
This is not an issue with the import but an issue with the export from the BC 6.0.2 environment. The issue is the participants with null values for guidelines (guidelines not being available during export) were not exported properly. When reviewing the export logs,  these type of strings indicate the issue.
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"Failed to process participant: TSTBIZ07-27xB: null. Skipping..."
java.io.FileNotFoundException: C:\opt\tibco\bc\6.0\protocols\tibedi\samples\sampleDocs\maps\5010_maps\276-X212_XE.map (The system cannot find the path specified)
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Issue/Introduction

All participants are not getting imported into a BusinessConnect installation.

Resolution

This issue has been fixed with BC 6.0.2 hf2.

Additional Information