Instancescould not be properly detected by object manager when using In Memory Mode with ConcurrentRTC.

book

Article ID: KB0089988

calendar_today

Updated On:

Products Versions
TIBCO BusinessEvents Enterprise Edition -
Not Applicable -

Description

Description:

Assume following scenario:

Object Management: In Memory
ConcurrentRTC: checked
Rule_1: newInstance() instance_1 and trigger Rule_2
Rule_2: get the instance_1 existing by getByExtId()

Sometimes we saw Rule_2 gives the instance_1 not existing information.


Symptoms:
From the log, we can see the Rule_2 gives the created instance is not existing. Sample log attached.

Cause:
There’s a change in BusinessEvents 5.1.2 compared with previous versions:

ConcurrentInMemoryObjectManager is the default.ConcurrentInMemoryObjectManager does not check if the handle is marked deleted.

Resolution

1). Use other versions earlier than BusinessEvents 5.1.2 .
2). Use BusinessEvents 5.1.2 but disable ConcurrentRTC.
3). Use BusinessEvents 5.1.2 and work around this issue by adding following property in CDD file:

be.engine.concurrentwm.enable.newImpl=false

Issue/Introduction

Instancescould not be properly detected by object manager when using In Memory Mode with ConcurrentRTC.

Additional Information

BE-20570