The BusinessConnect inbound file poller picks up the same file multiple times in a fault tolerant environment

The BusinessConnect inbound file poller picks up the same file multiple times in a fault tolerant environment

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Article ID: KB0089238

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Updated On:

Products Versions
TIBCO BusinessConnect -
Not Applicable -

Description

Description:
When two GS engines are running on two different machines and the file poller services is in the fault tolerant mode, the underlying RV communication issues can cause issues with the file poller services.

Symptoms:
Files can be polled and picked up a number of times within the polling interval. For example, if the polling interval if 1 minute, instead of polling the file once every 1 minute, the file poller would poll 6 times. Monitoring the network  we could see primary file poller service A getting deactivated, the secondary service B turning into an activated state ( turning to primary) but the original primary poller service A is still polling the folder.

Cause:
When a fault tolerant switch happens between the file poller service,  the secondary poller service assumes that the primary poller service has exited and turns into the primary. Under certain conditions, the secondary poller service becomes the primary, even though the primary service did not exit completely. Both will start to poll the same files.

Issue/Introduction

The BusinessConnect inbound file poller picks up the same file multiple times in a fault tolerant environment

Resolution

 If there are consistent network issues , it is better to run a single file poller service, thereby avoiding sending duplicate transactions to the TP. Defect BC-8055 has already been filed on this issue .

Additional Information

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