Platform application on SystemNode failed to start due to a database lock on governance agent runtime database (PRS_DB).

Platform application on SystemNode failed to start due to a database lock on governance agent runtime database (PRS_DB).

book

Article ID: KB0089459

calendar_today

Updated On:

Products Versions
TIBCO ActiveMatrix Service Grid -
TIBCO ActiveMatrix BusinessWorks Service Engine -
Not Applicable -

Description

Description:

Several platform application components/bindings are not being stopped or started on SystemNode which results in the platform application start failure. 


Symptoms:

The following exceptions can be seen repeatedly in the SystemNode logs and these are related to those components start/stop failures.

*************************************************************************

[ERROR] [] org.hibernate.util.JDBCExceptionReporter - The database is already in use by another process: lockFile:
org.hsqldb.persist.LockFile@d2746814[file =<CONFIG_HOME>/tibcohost/<host-instance>/data_3.2.x/nodes/<nodeName>/work/cf/<some-random-number>/work/GovernanceAgentRuntimeDB/PRS_DB.lck

*************************************************************************


Cause:
This PRS_DB.lck is related to the Agent database which is an internal database that is not supposed to be accessed externally. The PRS_DB.lck file is created when a connection to the agent database is open and it gets deleted automatically when the agent is shut down gracefully (on application stop or undeploy). It is possible that the .lck file may not have been removed if the application or agent did not shut down correctly.

Resolution

Stop the tibcohost associated with the problematic node where you have noticed the above mentioned PRS_DB.lck issues.

Backup and remove the lock file PRS_DB.lck from the above mentioned location.

Restart tibcohost.

If the platform is still in "Waiting for dependencies" or not in a running state then restart the components which are not yet in a started state under the application status tab.

Issue/Introduction

Platform application on SystemNode failed to start due to a database lock on governance agent runtime database (PRS_DB).

Additional Information