Connections fail while connecting to SQL Server in an environment configured with JRE 1.6.29 or later. Error: "[SQLServer JDBC Driver]Object has been closed."

Connections fail while connecting to SQL Server in an environment configured with JRE 1.6.29 or later. Error: "[SQLServer JDBC Driver]Object has been closed."

book

Article ID: KB0085212

calendar_today

Updated On:

Products Versions
TIBCO Runtime Agent (TRA) -
TIBCO Administrator -
Not Applicable -

Description

Description:

Unable to connect to SQL server while using the connect for JDBC SQL server driver after upgrading to JRE 6 update 29 or a later version. Error: "[SQLServer JDBC Driver]Object has been closed."


Symptoms:
Connections fail while connecting to SQL Server in an environment configured with JRE 1.6.29 or later. "[SQLServer JDBC Driver]Object has been closed.]"

Cause:
This is a known Microsoft defect.This issue occurs because the SQL Server engine cannot handle login records when SSL data is split into multiple Tabular Data Stream (TDS) packets.

Issue/Introduction

Connections fail while connecting to SQL Server in an environment configured with JRE 1.6.29 or later. Error: "[SQLServer JDBC Driver]Object has been closed."

Resolution

Install one of the following Microsoft Service Packs.

SQL Server 2012 Production version and later.
SQL Server 2008 Service Pack 3 Cumulative Update 4.
SQL Server 2008R2 Service Pack 1 Cumulative Update 6.
SQL Server 2008R2 Service Pack 2.

Workaround if it is not possible to immediately install/upgrade to the above SQL Server service pack follows:

1). Install JRE release 1.6.28 or earlier.

OR

2). Disable SSL record splitting at the JRE level. When running under Sun/Oracle  (TIBCO_SECURITY_PROVIDER=j2se) or IBM, add the following property to the BW Application TRA file or if you are running from Designer rather than in designer.tra.

java.property.jsse.enableCBCProtection=false

 Notes
  • Be aware that when selecting workaround 2 that this method might have security implications for HTTP communications.
  • Both workarounds should only be considered as temporary solutions. TIBCO Support recommends upgrading your MS SQL server to the service packs listed in this Solution.

Additional Information