Deploying process with EAI DB step from TIBCO Business Studio mixes up the order of Stored Procedure parameters.

Deploying process with EAI DB step from TIBCO Business Studio mixes up the order of Stored Procedure parameters.

book

Article ID: KB0085525

calendar_today

Updated On:

Products Versions
TIBCO Business Studio iProcess Add-in -
Not Applicable -

Description

Description:
Deploying a process from TIBCO Business Studio that contains a Database Service Task can result in the stored procedure parameters being in the wrong order causing the stored procedure to fail when run as a TIBCO iProcess EAIDB step.
Symptoms:
If the following parameters were defined in the order BBBB, AAAAAAA, CC, HHHHHH, EEEE, FFFFFF, DDDDD, GGGGGG, They would appear in the following order in Business Studio Service Task:

Parameter    Type    Data Field
BBBB        IN    B
AAAAAAA        IN    A
CC        IN    C
DDDDD        IN    D
HHHHHH        OUT    H
EEEE        OUT    E
FFFFFF        OUT    F
GGGGG        OUT    G

In the iProcess Modeler the EAIDB step would show the parameters in the following order,

BBBB
AAAAAAA    
CC
HHHHHH    
EEEE
FFFFFF
DDDDD
GGGGG

Cause:
Business Studio stores the set of stored procedure parameters in two different sets of content internally in the XPDL. One of these is sorted according to the Studio User Interface properties table order and one is not, it remains in the exact order of parameter creation. The iProcess Export is using the unsorted data set when converting to the EAIDB step.

Issue/Introduction

Deploying process with EAI DB step from TIBCO Business Studio mixes up the order of Stored Procedure parameters.

Resolution

Define all stored procedure parameters for the step in the exact order they are required.