SMTP Proxy issue with Inbox transport for B2B-X12 protocol.

SMTP Proxy issue with Inbox transport for B2B-X12 protocol.

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Article ID: KB0085531

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Updated On:

Products Versions
TIBCO BusinessConnect -
Not Applicable -

Description

Description:
 While trying to send an outbound transaction using the inbox as a transport, the BusinessConnect engine throws the following exception  " statusMsg=Notification did not reach trading partner. Failed to send Message, reason: No Transport reply On protocol B2B-X12.Missing host configuration in SMTP Proxy settings". 
Symptoms:
When sending an outbound transaction using inbox transport, the file does not get generated under the inbox virtual folder for the trading partner to pick it up when the trading partner connects to the SSHFTP server.
Cause:
The SMTP server  is not configured. 

Issue/Introduction

SMTP Proxy issue with Inbox transport for B2B-X12 protocol.

Resolution

Under Adminstrator-Business Connect -> System settings ->Outbound smtp proxy settings , add an SMTP server. Fill in the pertaining SMTP login information and unselect the proxy check-box under the Trading Partner configuration if you don't plan to use a proxy.