"ManagedConnection pool has been destroyed" exception during migration of database server for ActiveMatrix Administrator.

"ManagedConnection pool has been destroyed" exception during migration of database server for ActiveMatrix Administrator.

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Article ID: KB0085137

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Updated On:

Products Versions
TIBCO ActiveMatrix Service Grid -
TIBCO ActiveMatrix BusinessWorks Service Engine -
Not Applicable -

Description

Description:
"ManagedConnection pool has been destroyed" exception during migration of database server for ActiveMatrix Administrator.
Symptoms:
Steps followed to change ActiveMatrix Administrator database.

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Changing database details requires that you perform the following steps.

1).From the TIBCO Administrator user interface, stop the following applications:

-com.tibco.amx.commonlogging.logservice.app
-com.tibco.amx.commonlogging.payloadservice.app
-com.tibco.amx.mcr.aggregator

2).Uninstall the Teneo and Hibernate resource instances that the applications are using.

3). Uninstall the JDBC resource instances that the applications are using.

4).Start the TIBCO Configuration Tool and select Edit TIBCO ActiveMatrix Administrator Server Configuration - V3.2.

5).Select the enterprise and server name from the Server Configuration drop down menu and select Edit Database settings.

6).Edit the database configuration and click Configure. When the update is complete, TIBCO Configuration Tool restarts the SystemNode node.

7).When the SystemNode node becomes available, log in to the TIBCO Administrator GUI and update the JDBC resource templates of the applications stopped in step 1 with the new database information.

8).Install the JDBC, Teneo, and Hibernate resource instances.

9).Restart the three applications.

10).Restart the SystemNode node.

 *If the database URL is changed to point to a different database, make sure you migrate all data from the old database location to the new database location.You can do this migration after  step 3 in the above list (stop tibcohost and nodes, backup old amx admin db, migrate DB to new server, restart tibcohost and nodes ). Editing the configuration alone does not migrate the data.
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Problem. At Step 3 an exception was thrown ("ManagedConnection pool has been destroyed") while uninstalling JDBC resource instances for the Log Service or Payload Service.



Cause:
This is a document defect resolved in ActiveMatrix 3.3.0 . When uninstalling JDBC resource instances, confirm that the Governance JDBC shared resource instance must be the last to be uninstalled.

Issue/Introduction

"ManagedConnection pool has been destroyed" exception during migration of database server for ActiveMatrix Administrator.

Resolution

To recover from this exception, restart SystemNode and then continue to uninstall the remaining installed JDBC resource instances (Log Service and Payload Service).

The revised procedure for ActiveMatrix 3.2.0 Administrator follows:

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To change the database details, perform the following steps:

1). From the TIBCO Administrator user interface, stop the following applications from the System environment:

?com.tibco.amx.commonlogging.logservice.app
?com.tibco.amx.commonlogging.payloadservice.app
?com.tibco.amx.mcr.aggregator
 
2). Perform the following steps to uninstall the resource instances:

a).Make sure that you uninstall Log Service and Payload Service first. (TIBCO ActiveMatrix Payload Service Teneo Resource, TIBCO ActiveMatrix Log Service Teneo Resource).
 
b). Uninstall the Teneo resource instances from the system node (TIBCO ActiveMatrix Governance Teneo Resource).

c). Uninstall the Hibernate Resource Instance from the system node (TIBCO ActiveMatrix Governance Hibernate Resource).
 
d). Uninstall in the following order : Log Service or Payload Service in any order followed by the Governance JDBC shared resource instances from the system node. Ensure that the Governance JDBC shared resource instance must be the last to be uninstalled. It is recommended to use the Force Uninstall option for JDBC Resource Instance.

 If skipping  steps 3 to 7, restart the TIBCO Host manually.

3). If required, change the configuration of the user or database.

4). Start the TIBCO Configuration Tool and select Edit TIBCO ActiveMatrix Administrator Server Configuration - V3.2.
 
5).Select the enterprise name and server name from the Server Configuration drop down menu, and select Edit Database settings.

6).Edit the database configuration, then click Configure. When the update is complete, TIBCO Configuration Tool restarts the SystemNode node.

7). When the SystemNode node becomes available, log in to the TIBCO Administrator GUI and update the Governance JDBC resource with the new database configuration information. Cancel the pop-up to automatically synchronize the resource instances and applications.

8).Install the following:
 
a). JDBC Resource Instance for Governance JDBC Resource Instance. Make sure that Governance Service is installed before installing the Log and Payload Service.

b). Install the Hibernate Resource Instance (TIBCO ActiveMatrix Governance Hibernate Resource).
 
c). Install the Teneo Resource Instances. Make sure Governance Service is done first before installation of the Log and Payload Service.
 
If the data base URL is changed to point to a different database, make sure you migrate all the data from the old database location to the new database location. Editing the configuration alone does not migrate the data.
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