Startup of RulesManagementServer (RMS) fails when configured as a Windows service.

Startup of RulesManagementServer (RMS) fails when configured as a Windows service.

book

Article ID: KB0085850

calendar_today

Updated On:

Products Versions
TIBCO BusinessEvents Enterprise Edition -
Not Applicable -

Description

Description:
RMS server configured as a Windows Service.

- updated rms.tra
ntservice.name=be-rms
ntservice.displayname=TIBCO BE RMS 5.1.2
ntservice.starttype=automatic
ntservice.binary.path.absolute=C:/tibco/be/5.1/rms/bin/be-rms.exe
ntservice.interactive=false

Command to install RMS as a Windows service: "be-rms.exe --install"

Startup of RMS service failed (no logs in BE_HOME/rms/bin/logs).

Symptoms:
Service failed to start.

Cause:
Configuration issue - it is required to update BE_HOME\rms\bin\be-rms.tra

Issue/Introduction

Startup of RulesManagementServer (RMS) fails when configured as a Windows service.

Resolution

update tibco.env.APP_ARGS:
tibco.env.APP_ARGS=BE_HOME/rms/bin/RMS.ear -c BE_HOME/rms/bin/RMS.cdd -n rmsserver -u default

Example:

tibco.env.APP_ARGS=C:/tibco/be/5.1/rms/bin/RMS.ear -c C:/tibco/be/5.1/rms/bin/RMS.cdd -n rmsserver -u default


Note: By default, TIBCO BusinessEvents and ActiveSpaces log files are created in the Windows system (c:\windows\system) directory. Update the CDD to save the file in BE_HOME\rms\bin\logs.

1). BusinessEvents log file. 

- update logConfiguration settings in RMS.CDD and define a full path for the log directory

Example:
     <log-config id="logConfig1">
            <enabled>true</enabled>
            <roles>*:info</roles>
            <files>
                <enabled>true</enabled>
                <dir>C:\tibco\be\5.1\rms\bin\logs</dir>


2). TIBCO ActiveSpaces log file. 

- add a new property "be.engine.cluster.as.log.dir" (Cluster area) and define the log directory for TIBCO ActiveSpaces
 
Example:

 <property name="be.engine.cluster.as.log.dir" type="string" value="C:\tibco\be\5.1\rms\bin\logs"/>