Not able to download artifact from TIBCO ActiveMatrix Administrator internal port using a browser if the port is SSL enabled.

Not able to download artifact from TIBCO ActiveMatrix Administrator internal port using a browser if the port is SSL enabled.

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Article ID: KB0085448

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Updated On:

Products Versions
TIBCO ActiveMatrix Service Grid -
TIBCO BPM Enterprise (formerly TIBCO ActiveMatrix BPM) -
TIBCO ActiveMatrix BusinessWorks Service Engine -

Description

Description:
Not able to download artifact from TIBCO ActiveMatrix (AMX) Administrator internal port through a browser if the port is SSL enabled.

Symptoms:
When configuring TIBCO ActiveMatrix (AMX) Administrator, SSL is enabled on the internal HTTP port. Afterwards, when trying to download the following artifact from an internal port through a browser (IE).

https://WIN-0JM7EUIUFRU:19767/amxadministrator/svn/trunk/artifacts/keystore/admin_default_keystore.jceks

The browser reports the error,  "This page can't be displayed".
Cause:
This is expected behavior.

When the AMX Administrator internal HTTP port has SSL enabled, its SSL Certificate Source is the TIBCO Credential Server. The TIBCO Credential Server provides credentials that secure the management connections between the Administrator server, hosts and nodes. It is a mutual SSL configuration and is not expected to be accessed from the outside world, such as a browser.

Resolution

If there is a need to access a certain resource from a browser, use the external port instead (8120 by default). 

Example:

https://WIN-0JM7EUIUFRU:8120/amxadministrator/svn/trunk/artifacts/keystore/admin_default_keystore.jceks // SSL secured external port
http://WIN-0JM7EUIUFRU:8120/amxadministrator/svn/trunk/artifacts/keystore/admin_default_keystore.jceks // Default external port

Issue/Introduction

Not able to download artifact from TIBCO ActiveMatrix Administrator internal port using a browser if the port is SSL enabled.

Additional Information

N/A