TIBCO Nimbus Scheduled Reports do not show correct content

TIBCO Nimbus Scheduled Reports do not show correct content

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Article ID: KB0085438

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Updated On:

Products Versions
TIBCO Nimbus -
Not Applicable -

Description

Description:
Scheduled Reports do not show the correct content for the scope of diagrams that are selected
Symptoms:
Scheduled Reports do not show the correct content for the scope of diagrams that are selected and may differ from results shown when report is run manually
Cause:
TIBCO Nimbus Authors/Admins running reports do not have the account's 'See Draft Maps' option turned on for some reason. E.g. if an account was end user with this option turned off, and then has been changed to author/admin then this option remains turned off. This is a bug which will be investigated further.

Issue/Introduction

TIBCO Nimbus Scheduled Reports do not show correct content

Resolution

The work around to this problem is as follows:
1) Open the problem user (who created the report) properties, take a note of the options on the Settings page
2) Change Account Type to End User
3) Turn the 'Settings->Diagram->See Draft Maps' option on
4) Click OK to save changes
5) Open user's properties again
6) Change Account Type back to author/admin
7) Update the Settings page as required to restore initial state of the options
8) Click OK to save changes.
Note: clicking the Reset Settings button doesn't work without first changing Account Type.