Unable to identify the user making a service request

Unable to identify the user making a service request

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Article ID: KB0079040

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Updated On:

Products Versions
TIBCO BPM Enterprise (formerly TIBCO ActiveMatrix BPM) -
Not Applicable -

Description

Description:
This error is generally seen while processing a process instance, whose starter is no longer a BPM resource.

Symptoms:
An error similar to below is seen in the BPM logs -
 
"Unable to identify the user making a service request. [DCE7502C-8806-486F-A02D-B97D9FB19732,resolveResource]"
 
where DCE7502C-8806-486F-A02D-B97D9FB19732 - is the GUID of the deleted user
 
This error implies the following query has returned no results -
 
select * from de_resource where guid='DCE7502C-8806-486F-A02D-B97D9FB19732'

Cause:
Each process instance is assigned a principal, who is the process starter. A process starter must always exist on the system for a process instance to be completed successfully. If the user who is a principal of some process instances is deleted, then these process instances will fail to progress with the error mentioned in this KB article.

Issue/Introduction

Unable to identify the user making a service request

Environment

Product: TIBCO ActiveMatrix BPM Version: All Support Product Versions OS: All Supported Operating Systems --------------------

Resolution

Support for re-assignment of process instances for deleted users was added in TIBCO ActiveMatrix BPM v3.1.0.

Please refer product documentation - Openspace > Organization Browser User's Guide > Resources > Deleting Resources > Managing Deleted Users.

Additional Information

AMX BPM v4.2. Openspace > Organization Browser User's Guide > Resources > Deleting Resources > Managing Deleted Users - 

https://docs.tibco.com/pub/amx-bpm/4.2.0/doc/html/bpmhelp/GUID-ACFCE937-09D4-4CE9-9411-7B46DAA5F7E5.html

Please also review:
000034829
https://supportapps.tibco.com/ka/article/829/000034829.htm