TIBCO BusinessEvents (BE) Studio fails to start. WARNING.

TIBCO BusinessEvents (BE) Studio fails to start. WARNING.

book

Article ID: KB0093328

calendar_today

Updated On:

Products Versions
TIBCO BusinessEvents Enterprise Edition -
Not Applicable -

Description

Description:
After installation BE Studio fails to start when given the command 'studio -clean -initialize'.  There is no flash screen for Studio either for this command or starting it up without any command line parameters.

Symptoms:
In the installation log you will find lines similar to the following:
(10-06-2014.130741), ::WARNING::, The install assembly: product_tibco_wrapper can not be installed if a higher version exists in the same location., class com.tibco.installer.wizard.action.thread.TIBCOCheckAssemblyDowngrades
(10-06-2014.130741), ::WARNING::, disabling assembly: product_tibco_wrapper, class com.tibco.installer.wizard.action.thread.TIBCOCheckAssemblyDowngrades


Cause:
A higher version of the wrapper executable was found in the environment then what BE is attempting to install. The wrapper is copied and renamed to become the BE executable such as Studio, studio-tools and be-engine. Using a wrapper with a higher version than what BE would install can cause the BE executable to not start or to core dump. Hence, installing BE in a TIBCO_HOME which has TRA also installed can cause this problem.

Issue/Introduction

TIBCO BusinessEvents (BE) Studio fails to start. WARNING.

Resolution

Copying wrapper from a stand alone BE installation and renaming it to Studio, studio-tools and be-engine and any other BE executable. If you are installing BE 5.1.0 then upgrading to BE 5.1.3 may fix the problem. The wrap.exe will be found in BE_HOME\tools\wrapper. The version can be found by executing <executable> --version. 

Additional Information

The wrapper version with various versions of BE:
5.1.0 - 2.2.0 V12
5.1.1 - 2.2.0 V12
5.1.2 - 2.4.1 V3
5.1.3 - 2.4.1 V3