Installed software does not show in TIBCO Administrator GUI andOutOfMemoryError appears in the tsm.log

Installed software does not show in TIBCO Administrator GUI andOutOfMemoryError appears in the tsm.log

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Article ID: KB0093329

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Updated On:

Products Versions
TIBCO Runtime Agent (TRA) -
Not Applicable -

Description

Description:
For some domains which have large amount of applications deployed, when a new machine is added, software installed on the new machine does not always show up in TIBCO Administrator GUI. The TRA Hawk agent process may also consume a lot of CPU/memory resources and may eventually show OutOfMemoryError. 
Symptoms:
OutOfMemoryError resembling the following may be Observed.
 
java.lang.OutOfMemoryError: GC overhead limit exceeded
Dumping heap to /opt/tibco/TIBCOHOME1/tra/domain/ITG_01/tmp/hawkagent-dumps.hprof ...
Heap dump file created [941952387 bytes in 8.536 secs]
Exception in thread "TsmSyncInventory" java.lang.OutOfMemoryError: GC overhead limit exceeded
at java.util.Arrays.copyOf(Unknown Source)
at java.io.ByteArrayOutputStream.grow(Unknown Source)
at java.io.ByteArrayOutputStream.ensureCapacity(Unknown Source)
at java.io.ByteArrayOutputStream.write(Unknown Source)
at com.tibco.util.plugin.helpers.JarStreamClassPathResolver.streamToBytes(JarStreamClassPathResolver.java:145)
at com.tibco.archive.helpers.JarInputStreamClassPathResolver.<init>(JarInputStreamClassPathResolver.java:37)
at com.tibco.archive.impl.ApplicationArchiveImpl.<init>(ApplicationArchiveImpl.java:64)
at com.tibco.archive.helpers.ApplicationArchiveFactory.a(ApplicationArchiveFactory.java:130)
at com.tibco.archive.helpers.ApplicationArchiveFactory.getApplicationArchive(ApplicationArchiveFactory.java:96)
at com.tibco.pof.admindomain.impl.UploadedApplicationArchiveCache.getCachedUploadedApplicationArchive(UploadedApplicationArchiveCache.java:40)
at com.tibco.pof.admindomain.impl.DeploymentConfigurationImpl.getUploadedApplicationArchive(DeploymentConfigurationImpl.java:815)
at com.tibco.pof.admindomain.impl.DeploymentConfigurationImpl$ServiceOrderComparator.<init>(DeploymentConfigurationImpl.java:363)
at com.tibco.pof.admindomain.impl.DeploymentConfigurationImpl.getServiceConfigurations(DeploymentConfigurationImpl.java:407)
at com.tibco.pof.admindomain.impl.DeploymentConfigurationImpl.getServiceContainerBindings(DeploymentConfigurationImpl.java:1132)
at com.tibco.pof.admindomain.impl.ProductImpl.getApplicationConfigurations(ProductImpl.java:381)
at com.tibco.administrator.TSM.TSMFunctions.syncronizeProductsWithDomain(TSMFunctions.java:413)
at com.tibco.tra.tsm.TsmSyncInventory.run(TsmSyncInventory.java:102)

Cause:
The TRA Hawk Agent checks all deployed applications to see if any product might be previously used but is now uninstalled. Consequently, if a product, say, BW is heavily used and it is not installed on the new machine, TRA Hawk Agent will check all applications. This may cause  the OutOfMemoryError. 

Issue/Introduction

Installed software does not show in TIBCO Administrator GUI andOutOfMemoryError appears in the tsm.log

Resolution

Increase the max heap size of the TRA Hawk agent (java.heap.size.max in hawkagent_domainname.tra). It can be changed back to its default value once the installed products are synchronized. Alternatively, users can install the TIBCO product on the new machine and restart the TRA Hawk Agent.