'Year out of range ' error in the BPM log

'Year out of range ' error in the BPM log

book

Article ID: KB0083979

calendar_today

Updated On:

Products Versions
TIBCO BPM Enterprise (formerly TIBCO ActiveMatrix BPM) All supported versions of TIBCO ActiveMatrix BPM

Description

Description:
The following is seen in the BPM log file.

[PVM:DB Process Worker:10] [WARN ] org.hibernate.util.JDBCExceptionReporter - SQL Error: 17361, SQLState: 99999
[PVM:DB Process Worker:10] [ERROR] org.hibernate.util.JDBCExceptionReporter - Year out of range.

Symptoms:
Process Instance(s) go into a halted state.

Cause:
Enabling DEBUG on com.tibco.bx will show format of the date entered by the user was incorrect which in turn causes this error.

i.e., DateOfBirth field is in incorrect format

30 Oct 2014 11:08:28,208 [PVM:DB Process Worker:9] [DEBUG] com.tibco.bx.core.BxSystemImpl - [DEBUG] - {BX_TRACE} - updating var [DateOfBirth] with [19811-10-03] ¬{applicationActivityInstanceId=`pvm:001i5ltsv`, correlationId=``, principalName=`USER01`, threadId=`6534`, componentClassName=`com.tibco.bx.core.BxSystemImpl`, moduleName=`/modulev1_1/Process Packages/modulev1_1.xpdl`, hostAddress=`127.0.0.1`, compositeApplicationName=`amx.bpm.app`, nodeName=`BPMNode`, applicationActivityName=`init`, severity=`DEBUG`, eventType=`MESSAGE`, messageCategory=`PROCESS_INSTANCE`, componentId=`BX`, managedObjectName=`modulev1_1`, message=`updating var [DateOfBirth] with [19811-10-03]`, threadName=`PVM:DB Process Worker:9`, principalId=`3E1F7D6E-A25E-4A83-8F9F-4F698F23C975`, priority=`MEDIUM`, managedObjectId=`pvm:0a12u66`, environmentName=`BPMEnvironment`, hostName=`host01`, creationTime=`2014-10-30T11:08:28.208+0000`, messageId=`BX_TRACE`, ¬}

Issue/Introduction

"Year out of range" error in the BPM log.

Resolution

By default, TIBCO ActiveMatrix BPM does not parse the data field when entered to make sure it is in the correct format. Logic or Form parsing must be done at Design time to ensure this does not happen. Once the Process Instance is halted, you can update the correct field value using the following SOAP APIs and retry the Process Instance to continue.

getAvailableProcessInstanceVariables
setAvailableProcessInstanceVariables
retryProcessInstance

Additional Information

TIBCO ActiveMatrix BPM Developer's Guide > Process Manager Service