BusinessConnect EMS queues have message buildup.

BusinessConnect EMS queues have message buildup.

book

Article ID: KB0093303

calendar_today

Updated On:

Products Versions
TIBCO BusinessConnect -
Not Applicable -

Description

Description:
EMS queues associated with BusinessConnect operations (such as INITIATOR.RESPONSE or RESPONDER.ACK) have a large number of messages accumulate in them.  The number of messages continually increases.
Symptoms:
From the EMS Administrator, running the "show queues" command lists BusinessConnect EMS queues with increasing number of messages.
Cause:
The BC EMS queues do not have BW projects subscribing to them. This can be confirmed by observing the Receiver Count in the "show queues" command mentioned previously.  A count of zero (0) indicates that there are no listeners.

Issue/Introduction

BusinessConnect EMS queues have message buildup.

Resolution

This condition can be remedied either by:

1). Creating BW projects in the environment to subscribe to these queues and then discarding the messages.

2). Configure the specific EMS queue to expire the message after a specific interval. See the EMS configuration guide for details on to how to configure the queue.

Additional Information

EMS documentation