TIBCO Configuration Tool ("TCT") wizard faild to create an TIBCO ActiveMatrix ("AMX") Administrator instance due to "critical error while initializing TIBCO ActiveMatrix Administrator Server".

TIBCO Configuration Tool ("TCT") wizard faild to create an TIBCO ActiveMatrix ("AMX") Administrator instance due to "critical error while initializing TIBCO ActiveMatrix Administrator Server".

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Article ID: KB0093240

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Updated On:

Products Versions
TIBCO ActiveMatrix Service Grid -
TIBCO BPM Enterprise (formerly TIBCO ActiveMatrix BPM) -
TIBCO ActiveMatrix BusinessWorks Service Engine -

Description

Description:
Unable to create an AMX Administrator instance when running TCT wizard. After 10 minutes the following is thrown: "TIBCO-AMX-ADMIN-004052: Timed out".

Symptoms:

TCT wizard will fail to build an AMX Administrator instance with the following error:

21 May 2014 10:27:44,928 [WAR-Deployer-Thread] [ERROR] [] com.tibco.amx.admin.server -
21 May 2014 10:27:44,929 [WAR-Deployer-Thread] [ERROR] [] com.tibco.amx.admin.server - ******************************************************
21 May 2014 10:27:44,929 [WAR-Deployer-Thread] [ERROR] [] com.tibco.amx.admin.server - TIBCO-AMX-ADMIN-004061: There was a CRITICAL ERROR while initializing TIBCO ActiveMatrix Administrator Server
21 May 2014 10:27:44,929 [WAR-Deployer-Thread] [ERROR] [] com.tibco.amx.admin.server - ******************************************************
21 May 2014 10:27:44,930 [WAR-Deployer-Thread] [ERROR] [] com.tibco.amx.admin.server -
com.tibco.amf.admin.api.core.exception.AdminException
summary = TIBCO-AMX-ADMIN-004052: Timed out. Waited for 10 minutes to allow platform application to complete its deployment on the Admin node, but it is still not finished yet. This usually indicates a problem has occurred.

        at com.tibco.amf.admin.server.AdminInitServlet.waitUntilTaskFinish(AdminInitServlet.java:350)
        at com.tibco.amf.admin.server.AdminInitServlet.init(AdminInitServlet.java:155)
        at org.mortbay.jetty.servlet.ServletHolder.initServlet(ServletHolder.java:431)
        at org.mortbay.jetty.servlet.ServletHolder.doStart(ServletHolder.java:263)
        at org.mortbay.component.AbstractLifeCycle.start(AbstractLifeCycle.java:50)
        at org.mortbay.jetty.servlet.ServletHandler.initialize(ServletHandler.java:681)
        at com.tibco.amf.hpa.tibcohost.jetty.deployer.support.EMFSupportServletHandler.initialize(EMFSupportServletHandler.java:123)
        at org.mortbay.jetty.servlet.Context.startContext(Context.java:140)
        at org.mortbay.jetty.webapp.WebAppContext.startContext(WebAppContext.java:1250)
        at org.mortbay.jetty.handler.ContextHandler.doStart(ContextHandler.java:517)
        at org.mortbay.jetty.webapp.WebAppContext.doStart(WebAppContext.java:467)
        at com.tibco.amf.hpa.tibcohost.jetty.deployer.WarDeployer$4.doStart(WarDeployer.java:314)
        at org.mortbay.component.AbstractLifeCycle.start(AbstractLifeCycle.java:50)
        at com.tibco.amf.hpa.tibcohost.jetty.ConnectorInfo.addContext(ConnectorInfo.java:909)
        at com.tibco.amf.hpa.tibcohost.jetty.internal.JettyManager.addContext(JettyManager.java:816)
        at com.tibco.amf.hpa.tibcohost.jetty.deployer.WarDeployer.startDeployment(WarDeployer.java:429)
        at com.tibco.amf.hpa.tibcohost.jetty.deployer.WarDeployer.doDeploy(WarDeployer.java:238)
        at com.tibco.amf.hpa.tibcohost.jetty.deployer.WarDeployer.access$2(WarDeployer.java:231)
        at com.tibco.amf.hpa.tibcohost.jetty.deployer.WarDeployer$3.run(WarDeployer.java:190)
        at java.util.concurrent.ThreadPoolExecutor.runWorker(Unknown Source)
        at java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown Source)
        at java.lang.Thread.run(Unknown Source)
Cause:
This issue is usually related to EMS server connectivity.

Resolution

Check the following:

1). Make sure the EMS server is used by only one AMX enterprise instance.
2). Verify that the EMS server is up and running and is accessible from the machine where you are trying to build the AMX Administrator instance.
3). In the case of SSL enabled EMS servers, make sure you are pointing to the correct KeyStore.
4). Make sure the EMS Server version is supported by the AMX Service Grid.

Contact TIBCO Support with following information in case the problem persists. 

- AMX product version and hotfix level
- EMS version
- Complete TCT console output, tibcohost.log and SystemNode.log

Issue/Introduction

TIBCO Configuration Tool ("TCT") wizard faild to create an TIBCO ActiveMatrix ("AMX") Administrator instance due to "critical error while initializing TIBCO ActiveMatrix Administrator Server".

Additional Information