BusinessConnect icon does not appear in the Administrator after installation.

BusinessConnect icon does not appear in the Administrator after installation.

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Article ID: KB0093394

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Updated On:

Products Versions
TIBCO BusinessConnect -
Not Applicable -

Description

Description:
After installing the BC Internal Server and Gateway server on a single machine, the BusinessConnect icon on the left panel in the Administrator does not appear.
Symptoms:
As described. Importing the bcadminweb.war file has no effect.


Cause:
The JMS client libraries are missing from the classpath in the Administrator.tra file. The EMS libraries were removed from TRA 5.9, and must be installed separately.

Issue/Introduction

BusinessConnect icon does not appear in the Administrator after installation.

Resolution

After installing the EMS client libraries, run the following TRA upgrade script

traUpgraderManager.exe -ems < ems library location i.e c:\tibco\ems\8.0> -path <your home tibco directory>

This utility will add the EMS class path into all TRA files under the directory. Note. if running the Admininstrator as a Windows server, you must un-install and re-install the Windows service after running the traUpgraderManager.




Additional Information

TIBCO Runtime Agent Release Notes.