TIBCO BusinessWorks ProcessMonitor client install issue.

TIBCO BusinessWorks ProcessMonitor client install issue.

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Article ID: KB0093638

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Updated On:

Products Versions
TIBCO BusinessWorks ProcessMonitor -
Not Applicable -

Description

Description:
Usually, non-invasive monitoring mode is applicable only to deployed applications. You cannot use this mode while running a project from Designer. However, you can follow the steps below in the Resolution as a workaround.
Symptoms:
When a user attempts to run a pure TIBCO ActiveMatrix BusinessWorks project from Designer in non-invasive monitoring mode, it will not send events to the TIBCO BusinessWorks ProcessMonitor server. Users will not be able to monitor processes in non-invasive monitoring mode.
Cause:
In non-invasive monitoring mode, you modify the engine.tra/application.tra by adding NJAMS properties. Deployed applications will use the settings and will send events to the TIBCO BusinessWorks ProcessMonitor server. Designer Tester does not recognize the NJAMS properties of the engine.tra and will run as a pure TIBCO ActiveMatrix BusinessWorks application.

Issue/Introduction

TIBCO BusinessWorks ProcessMonitor client install issue.

Resolution

1). In the existing project, create a dummy process with one TIBCO BusinessWorks ProcessMonitor (BWPM) client pallet (BWPM Client log activity).

2). Configure all BWPM Client global variables as per your environment.

3). Load this dummy process along with your TIBCO ActiveMatrix BusinessWorks (BW) process in Tester.

4). Run the BW process.

Note that there is no need of updating any .tra (even designer.tra) file for configuring TIBCO BusinessWorks BWPM. Just ensure all BWPM Client global variables are correctly configured.