Error: "Connection to BW Agent failed" when registering bwagent with TIBCO Enterprise Administrator (TEA).

Error: "Connection to BW Agent failed" when registering bwagent with TIBCO Enterprise Administrator (TEA).

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Article ID: KB0074996

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Updated On:

Products Versions
TIBCO Enterprise Administrator (TEA) -
Not Applicable -

Description

Description:
When starting bwadmin and trying to register bwagent using  the "registerteaagent http://<host>:<port>/tea/" command, it fails and returns an error.
Symptoms:
The following error will be returned in bwadmin:
 
"TIBCO-BW-ADMIN-500008: Error in initializing data manager, TIBCO-BW-ADMIN-PRSTNC-500001: Connection to BW Agent failed"

Cause:
The bwagent needs to be running in order for the bwadmin to register the agent with the TEA server.

Issue/Introduction

Error: "Connection to BW Agent failed" when registering bwagent with TIBCO Enterprise Administrator (TEA).

Resolution

Execute the bwagent under %BW_HOME%/6.x/bin before trying the bwadmin registerteaagent command.

Please contact TIBCO support if you still have problems. 

Additional Information

BusinessWorks Administration document ->  Using bwagent with TEA -> Registering bwagent with TIBCO Enterprise Administrator