TIBCO ActiveMatrix BusinessWorks Plug-in for WebSphere MQ reconnection failure to reconnect due to an IBM MQ client issue.

TIBCO ActiveMatrix BusinessWorks Plug-in for WebSphere MQ reconnection failure to reconnect due to an IBM MQ client issue.

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Article ID: KB0093622

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Updated On:

Products Versions
TIBCO ActiveMatrix BusinessWorks Plug-in for IBM MQ -
Not Applicable -

Description

Description:
When using WMQ Connection plug-in with pooling enabled, the plug-in activity fails to reconnect to MQ server when there is a network outage. This is due to an IBM MQ client issue which is recorded in IBM APAR IT02422. That issue is fixed in IBM MQ client version 7.5.0.5, 8.0.0.1 and above.
Symptoms:
The following error message in a BW application log file means the MQ plug-in has a problem connecting to the queue manager.

2014 Apr 16 12:21:47:024 GMT +1 BW.MQ_Plugin_listen_iterate Error [BW-Core] BWENGINE-100001 Listener/Subscriber informational message: Error connecting to queue manager: Error connecting to queue manager: {port=6469, hostname=star, channel=ZM.CH1}
MQRC_HOST_NOT_AVAILABLE 

Cause:
The connection is not marked as available and returned to the pool after a network outage.

Issue/Introduction

TIBCO ActiveMatrix BusinessWorks Plug-in for WebSphere MQ reconnection failure to reconnect due to an IBM MQ client issue.

Resolution

Update to MQ Client versions 7.5.0.5, 8.0.0.1 or above or request a patch for issue APAR IT02422.