EMSCA only allowing new stores to be created on the HDD drive on the very first setup of an TIBCO-EMS-HI Appliance

EMSCA only allowing new stores to be created on the HDD drive on the very first setup of an TIBCO-EMS-HI Appliance

book

Article ID: KB0093627

calendar_today

Updated On:

Products Versions
TIBCO Enterprise Message Service Appliance -
Not Applicable -

Description

Description:

SCOPE: 
This only affects TIBCO-EMS-HI appliances that have never been reset using ‘reset-all’ or ‘reset-hard’.

When a TIBCO-EMS-HI appliance is setup for the very first time, the generated server JSON always is based on a STD appliance template instead of the HI appliance template.
This results in all the store files being placed on the HDD drive, and EMSCA only allowing new stores to be created on the HDD drive(none on the SSD drive where the normal default stores should be placed).
All store files will be located on the HDD harddisk instead of the SSD solid-state drive.


RESOLUTION:
You can resolve this issue by using EMSA CLI command “reset-all”.
 
Following the setup/upgrade procedures below (which have been commonly used in the past) will resolve the problem.
 
 
DETAILS:
 
When a TIBCO-EMS-HI appliance is setup for the very first time, the generated server JSON always is based on a STD appliance template instead of the HI appliance template. This results in all the store files being placed on the HDD drive, and EMSCA only allowing new stores to be created on the HDD drive (none on the SSD drive where the normal default stores should be placed).
REMEDY: For a mis-configured appliance. Use the commands:
emsacli> support-enable
emsacli> reset-all

User will be logged out of the CLI and need to log back in and re-setup
NOTE: defaults from previous setup will be remembered as the default for each question.
NOTES:
– All post-setup modifications made to the JSON will be lost and need to be re-applied.
– Gateway Management: If an EMS-Gateway is already active, it will be reset by 'reset-all' to the mgmt-gateway, so the user will need to log back in to re-run setup using the mgmt-IP address.

RECOMMENDED FIRST-TIME INSTALL PROCEDURE:
In light of this issue, it is recommended as the following:
1. Run an initial setup without specifying an EMS-gateway, and choosing "no FT" and choosing "no DR" (to minimize the number of questions).
NOTE: Not specifying the EMS-gateway during the preliminary setup avoids the complications of gateway switching during this process.
2. Log in and apply any required software upgrades.
3. Log in and reset the appliance
emsacli> support-enable
emsacli> reset-all
-- this will log the user out and set the mgmt-gateway as active
-- Caution: If the server is already part of an operational FT-pair, servers on the peer should be stopped so that the "bad" configuration does not get replicated back to this appliance after the fresh setup.
4. Log in and re-run the setup dialog specifying the full desired setup
.. answers from first setup will be remembered and used as defaults

DIAGNOSIS:
To check whether or not an appliance has been impacted by this issue:
-- use 'setup-show' to display the 'EMS Hardware Type' - TIBCO-EMS-STD appliances are not impacted, TIBCO-EMS-HI may be impacted - see below.
Checking the store file $sys.meta
-- Connect to an active server with EMSCA or the support command 'call-tibemsadin', to show the details of EMS store file '$sys.meta'
If the FILE is SSD/meta.db, it is configured correctly, if it is HDD/meta.db, the issue is present and needs to be resolved.
(Alternatively: 'export config' or 'export-support-logs' can be used to export a copy of the server json files, and the "stores" section of the JSON can be examined to see if $sys.meta is on the hddpool or fusionpool (may show as HDD/ or SSD/ ))
 
For more detail reset-all steps, please refer to KB: 42818 -> How to fix mis-configured FT EMSA appliance json config file.

Issue/Introduction

EMSCA only allowing new stores to be created on the HDD drive on the very first setup of an TIBCO-EMS-HI Appliance