TIBCO BusinessWorks ProcessMonitor (BWPM) throws the error message, "NJAMS_JOB_TRACK_TEMPLATES_UPDATE_LAST_REF couldn't execute job".

TIBCO BusinessWorks ProcessMonitor (BWPM) throws the error message, "NJAMS_JOB_TRACK_TEMPLATES_UPDATE_LAST_REF couldn't execute job".

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Article ID: KB0093341

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Updated On: 01-13-2017

Products Versions
TIBCO BusinessWorks ProcessMonitor -
Not Applicable -

Description

Description:
For every subsequent execution attempt of the job, NJAMS_JOB_TRACK_TEMPLATES_UPDATE_LAST_REF, the error "NJAMS_JOB_TRACK_TEMPLATES_UPDATE_LAST_REF couldn't execute job" is logged. Note that this error will not cause any data to be lost.


Symptoms:
TIBCO BusinessWorks ProcessMonitor (BWPM) Server throws the error, "NJAMS_JOB_TRACK_TEMPLATES_UPDATE_LAST_REF couldn't execute job" in the log file.

Cause:
This error occurs because the job NJAMS_JOB_TRACK_TEMPLATES_UPDATE_LAST_REF tries to start every minute but needs more than one minute (approximately 70 to 75 seconds) to execute. As the previous job is not finished the job cannot be executed and the error "NJAMS_JOB_TRACK_TEMPLATES_UPDATE_LAST_REF couldn't execute job" is thrown.

Issue/Introduction

TIBCO BusinessWorks ProcessMonitor (BWPM) throws the error message, "NJAMS_JOB_TRACK_TEMPLATES_UPDATE_LAST_REF couldn't execute job".

Resolution

Upgrade to TIBCO BusinessWorks ProcessMonitor (BWPM) 3.0.0 as this issue is addressed in the BWPM 3.0.0 release.