EMS server reported, "SEVERE ERROR: Persisted message possibly corrupted: no sequence id" each time when it was restarted.

EMS server reported, "SEVERE ERROR: Persisted message possibly corrupted: no sequence id" each time when it was restarted.

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Article ID: KB0093590

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Updated On:

Products Versions
TIBCO Enterprise Message Service -
Not Applicable -

Description

Description:
EMS server reported, "SEVERE ERROR: Persisted message possibly corrupted: no sequence id" each time when it was restarted.


Symptoms:
The EMS server reported, "SEVERE ERROR: Persisted message possibly corrupted: no sequence id" for each restart using the same db files.


Cause:
A message was corrupted such that sequence number is 0. This message was already consumed and the message record is marked as free space *during* the recovery. Until the free space is reclaimed, each restart would report the same error, "SEVERE ERROR: Persisted message possibly corrupted: no sequence id", to indicate the message is corrupted. 

Issue/Introduction

EMS server reported, "SEVERE ERROR: Persisted message possibly corrupted: no sequence id" each time when it was restarted.

Resolution

If you run the "compact" command in the tibemsadmin tool, it will most likely get rid of this record. You could also send PERSISTENT messages to the EMS server so that the free space with the corrupted message record could be reclaimed. You'll see that this record will no longer be an issue at the next restart. The message corruption with sequence number 0 usually is due to something being written inside that record and causing the corruption. Refer to the KB: 25727 to investigate further the possible root causes of message corruption.

Additional Information

KB: 25727