Schema validation error for outbound message listener in TIBCO ActiveMatrix BusinessWorks Plug-in for Salesforce.com.

Schema validation error for outbound message listener in TIBCO ActiveMatrix BusinessWorks Plug-in for Salesforce.com.

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Article ID: KB0093560

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Updated On:

Products Versions
TIBCO ActiveMatrix BusinessWorks Plug-in for Salesforce.com -
Not Applicable -

Description

Description:
The plug-in outbound message listener validates the message it receives from Salesforce. If the message is not valid per the defined schema, which is imported from Salesforce as an WSDL file, it will log an error and send an ACK with "True".

Symptoms:
Below is the error you seen in the BW engine log file.

2013 Dec 08 23:14:45:828 GMT -8 BW.MickOutboundTest2 Info [BW-Plugin] BW-Salesforce-200092 The Salesforce Outbound Message Listener received a message whose ServiceEntry URL is [ http://220.231.14.20:8443/foldername/processname ].
2013 Dec 08 23:14:46:000 GMT -8 BW.MickOutboundTest2 Info [BW-Plugin] BW-Salesforce-200087 The Salesforce Outbound Message Listener received a message whose ServiceEntry URL is [ http://220.231.14.20:8443/foldername/processname ]. Sending an Ack: [ true ].
2013 Dec 08 23:14:46:015 GMT -8 BW.MickOutboundTest2 Error [BW-Core] BWENGINE-100031 Job-4000 Error in [foldername/processname.process/Salesforce Outbound Message Listener]
Output data invalid......

Cause:
This is caused by the schema in Salesforce side is out of sync with the schema in plug-in side. Either the schema has changed or the schema in plug-in side is out of date.

Issue/Introduction

Schema validation error for outbound message listener in TIBCO ActiveMatrix BusinessWorks Plug-in for Salesforce.com.

Resolution

This issue can be resolved by synchronizing the schema between the object in Salesforece and the one in the plug-in, which can done by exporting the WSDL from Salesforce and importing it into the plug-in.


Version 2.4.1 HF 1 implements an enhancement by sending a negative ACK to Salesforce. Salesforce will try to send the same message again, which finally causes the message sending failure since the message has a schema issue that can't be consumed. There's a mail notification function on the Salesforce side for an outbound message that fails to be delivered. Once that function is enabled, the user is able to get attention on a failed delivered outbound message. Further action can then be taken to review the message and resolve the issue.

To enable mail notification for failed delivered outbound message, ask Salesforce support to turn on "enabling outbound messages" explicitly. See https://help.salesforce.com/apex/HTViewHelpDoc?id=workflow_outbound_messages_notifications.htm.  After that, you will see "Outbound Message Notification" option right underneath "Outbound Messages" in the "Monitoring" section of Setup.


Additional Information

https://help.salesforce.com/apex/HTViewHelpDoc?id=workflow_outbound_messages_notifications.htm.